WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Add-ons

ABS - Advanced Ban System

— Add-On pour WorldWideScripts.net

@fr1wwsAbonnez-vous à notre RSS pour rester à jour!

Nouveau! Suivez-nous que vous le souhaitez!


ABS - Advanced Ban System - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Qu'est-ce que ce script à propos?

ABS - Système Ban Advanced est une application PHP conçu pour maintenir le trafic unwated depuis votre site. Vous pouvez interdire les utilisateurs par leur adresse IP, par plages d'adresses IP, par le système d'exploitation, par navigateur, par pays, UserAgent ou Referer. Vous pouvez également ajouter une date d'expiration, la raison de l'interdiction, ou un chemin où l'interdiction est actif. utilisateurs interdits ne sont pas en mesure de voir le contenu du site, mais ils seront en mesure de vous envoyer un message, demandant leur IP pour obtenir unbanned, de cette façon, vous avez toujours moyen de communiquer avec les utilisateurs interdites. Le script dispose également d'une passerelle API, qui peut être utilisé pour ajouter des interdictions. Le panneau d'administration a un design propre et il s `écrit en AJAX. It`s également très facile à installer et il a de faibles exigences, vous avez seulement besoin d'un domaine / sous-domaine avec PHP 5.x et Mysql, fonction CURL activé et GD lib.

Comment puis-je mettre en œuvre avec mon site existant?

Eh bien, il s `assez simple, la seule chose que vous avez à faire, est d'inclure cette ligne de code dans les fichiers que vous souhaitez protéger avec ABS.

 <? Php require_once ( 'abs / php / abs.php'); ?> 

La documentation contient plus d'informations sur implentation, y compris des instructions sur la mise en œuvre avec wordpress et joomla.

Note * Ce n'est pas plugin wordpress / joomla natif, vous ne pouvez pas l' installer comme un joomla / plugin wordpress.

Vérifiez la démo:

Page Admin: ABS Connexion

Utilisateur: admin passe: admin

Page avec le script actif: ABS Page de test

Mises à jour:

23.06.2015 [1,5]

  • Plusieurs améliorations UI & UX
  • - Migrés à Bootstrap 3
  • - Bouton manquant Ajout et étiquette icônes
  • - Plusieurs bogues liés à la conception fixe
  • Plusieurs améliorations de workflow d'installation
  • - Maintenant le fichier install.phpp auto suppressions
  • - Vous ne pouvez pas accéder au panneau w / o l' installation
  • - Entrées en direct validateurs et plus
  • Plusieurs modifications de structure
  • - Ajout de nouveaux libs
  • - Refractored quelques morceaux de code
  • Plusieurs correctifs de bugs

26.11.2013 [1.3]

  • Correction d' un bug sur "banned.php"
  • Modifié panneau d'administration, de sorte que vous vous interdisez gagné le `t

23.10.2013 [1.2]

  • Remplacement de l'ancien système buggy captcha par un nouveau
  • Autres bugs mineurs

12.07.2013 [1.1]

  • Correction du bug de captcha
  • Autres bugs mineurs

Télécharger
D'autres éléments de ce typeTous les composants de cet auteur
CommentairesFoire aux questions et réponses

Propriétés

Créé:
3 Juillet 13

Dernière mise à jour:
23 Juin 15

Haute résolution:
Non

Navigateurs compatibles:
IE6, IE7, IE8, IE9, IE10, Firefox, Safari, Opera, Chrome

fichiers inclus:
JavaScript JS, HTML, CSS, PHP

Une version de logiciel:
PHP 5.x, MySQL 5.x

Mots-clés

commerce é, lectronique, commerce é, lectronique, Tous les articles, abdos, systè, me d'interdiction avancé, e, navigateur interdiction, pays d'interdiction, interdiction os, systè, me interdisant, interdiction de php, php interdiction, php systè, me interdisant, unban